Pedal manufacturers in here...

Moderators: Slowy, Capt. Black

User avatar
BY jeremyb
#672989
Not mine, but handmade, this is awesome!

Image
User avatar
BY bbrunskill
#677686
Not home made, but GREAT SUCCESS! I bought a dead DD-3 for $20 on YouFaceTwit, and managed to fix it! 4 main issues:

1) incorrect power supply has been used at some point, cooking the protection diode and burning out the PCB. I replaced the diode with an LED as I didn't have a zener, and repaired 3 tracks that were trashed. That got voltage going into the circuit, but it still didn't go . . .

2) found and repaired some awful soldering. Someone has tried to 'fix' this thing before

3) Still didn't go. I started gently pulling the wires coming off the PCB to see if any were loose, found one going to the mode knob which was just barely hanging on. Took it out and soldered in a new wire and boom. Delay was baccck! but no LED.

4) resoldered 4 solder joints that connect the LED to the PCB, and that was back as well.

Feeling rather chuffed with myself. Now to go do all the house work that I was suppose to be doing this morning.
User avatar
BY TmcB
#677687
Very well done, particularly if 9VAC had been smacked in there – if you want to really destroy a pedal this is the way to do it, short of throwing it in a volcano.
User avatar
BY jimi
#677688
TmcB wrote:Shit, things have got next level around here.

A challenger appears!

Image


Image

Seriously though... that looks awesome... and bonus, no comic sans in sight.

How do I acquire one of these?
User avatar
BY jeremyb
#677689
bbrunskill wrote:Not home made, but GREAT SUCCESS! I bought a dead DD-3 for $20 on YouFaceTwit, and managed to fix it! 4 main issues:

1) incorrect power supply has been used at some point, cooking the protection diode and burning out the PCB. I replaced the diode with an LED as I didn't have a zener, and repaired 3 tracks that were trashed. That got voltage going into the circuit, but it still didn't go . . .

2) found and repaired some awful soldering. Someone has tried to 'fix' this thing before

3) Still didn't go. I started gently pulling the wires coming off the PCB to see if any were loose, found one going to the mode knob which was just barely hanging on. Took it out and soldered in a new wire and boom. Delay was baccck! but no LED.

4) resoldered 4 solder joints that connect the LED to the PCB, and that was back as well.

Feeling rather chuffed with myself. Now to go do all the house work that I was suppose to be doing this morning.


Achievement unlocked! Thats awesome!
User avatar
BY TmcB
#677691
jimi wrote:
TmcB wrote:Shit, things have got next level around here.

A challenger appears!

Image


Image

Seriously though... that looks awesome... and bonus, no comic sans in sight.

How do I acquire one of these?


Thank you sir!
Well, I'd ask Bender what he thinks of his first, and then drop me an email at tony@silverpistoleffects.com
User avatar
BY Kev77
#793416
With all the house moves etc I've "past participle of get" out of the pedal box pimping , but for a friends bday a mate and I collaborated on this wee gem. Thought I'd share it here. I haven't built anything in ages but thought I'd have a go again,

Image
User avatar
BY Single coil
#793428
I just realised the knobs are different. That’s cool as.
  • 1
  • 103
  • 104
  • 105
  • 106
  • 107